Strony: [1]   Bottom Do dołu
   Drukuj   
ico Autor    
[EN] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [RU]
     Topic: Błędy parsowania  [Przeczytany 3785 razy]
0 użytkowników i 1 Gość przegląda ten wątek.
Technik
*****
Offline
25.12.2013 19:54:28
Topic Starter
 Poland Mężczyzna
Poland
 
DATA: [11.07.2009 23:20:18] Błędy parsowania
Link:  https://poligon.ricoroco.com/fora/smf/index.php?topic=309.msg867#msg867  
Siema

Tym razem mam gigantyczny problem.

Po zmianie stylu postanowiłem odinstalować kilka zbędnych modów. I od tego zaczęły się moje problemy. Jeżeli instaluje mod -> Mam błąd parsowania, odinstalowuje mod -> błąd parsowania, czyszczenie cache -> bląd parsowania.

Zauważyłem w podanych plikach, że zawsze woła o niespodziewany "?" . No więc okazuje się, że to chyba po starych moda pozostały cię znaczki : "<?"
Robiłem to ręcznie usuwając je i wgrywając ponownie poprawiony plik i wszo było ok.

Ale teraz padła mi rejestracja!!!  krzyk

Po wpisaniu wszystkich danych do rejetracji przekierowuje usera na strone gdzie pisze WYSTĄPIŁ BŁĄD!
Tylko, że nie ma podane jaki to błąd. Zauważyłem też, że dzisiaj co kolwiek zatwierdzam w PA mam błąd parsowania  krzyk

Więc ogólnie wszystko legło a nie mam ciągle czasu wgrywać ręcznie na ftp poprawionych plików.
Nie da się tego jakoś naprawić?
Czyszczenie cache nie pomaga bo zaraz po wyczyszczeniu pojawia się, że wyczyszczono i wszo ok ale jak wcisne cokolwiek innego od razu pojawia się błąd parsowania ... nie mam już pomyslu co z tym zrobic?

wersja smf 2.0



Attention! Testing modifications - Steam Profile

IP IP Zapisane
Administrator
*****
Imagination is more Important than Knowledge
Offline
08.05.2017 21:24:16
 United States Mężczyzna
United States
  WWW
DATA: [12.07.2009 02:26:14] Odp: Błędy parsowania
Link:  https://poligon.ricoroco.com/fora/smf/index.php?topic=309.msg868#msg868 Post #1 
Sorry Draco, dopiero zwaliłem na chatę..

Rozumiem, że po oczyszczeniu cache forum, oczyściłeś również cache przeglądarki i odświeżyłeś parę razy?

Trudna sprawa, bo za mało info.. ale po kolei.
Musisz cofnąć zmiany, tj. jeśli odinstalowałeś moda, to teraz musisz rozpakować paczkę i podejrzeć instalkę, albo sparsować tam gdzie się pobiera moda. Chodzi o to, że mod ma instrukcje - "co gdzie idzie" i trzeba podejrzeć te pliki, w których miały się dokonać zmiany. Ponadto smf robi kopię bezpieczeństwa głównych plików w katalogu Packages/Backup. Więc można w razie co zaczerpnąć stamtąd plików. Oczywiście musisz dołożyć do tego Twoje własne zmiany.
Czy po odinstalowaniu każdego z modów, dokonałeś optymalizacji na swoim hostingu w PhpMyAdminie?

Powinieneś ustalić, czy wszystko się prawidłowo odinstalowało, a szczególnie, że sam dokonywałeś zmian również.
Jak rozumiem to gł. integra z innymi stylami.. Czy styl został zmieniony, można podmienić niektóre pliki z czystej instalki, lub wybrać styl, na którym nie były dokonane zmiany. Ważne są też błędy które generuje sam smf, ponieważ pokazuje w ten sposób co mu dolega..

Niestety informacje które podałeś są nie wystarczające, żeby można było zrozumieć problem szczegółowo.

Powiem Ci jak ja to robię..

Zanim zainstaluje cokolwiek:
- dokonuję "sprawdzenia i naprawy", przeglądam logi błędów, czyszczę logi i optymalizuję bazę, oraz pobieram kopię bazy.
- dodatkowo, pobieram kopię bazy z hostingu via PMA
- jeśli mod modyfikuje jakieś tabele w bazie to exportuję dodatkowo tylko te tabele.
- ściągam z ftp pliki które mają zostać zmodyfikowane do katalogu na dysku o nazwie danego moda z dopiskiem "przed_Nazwa_Moda", (ordnung muss zein hehe).

W takim wypadku, jeśli coś nie pójdzie po myśli, to tylko dokonuję odwrotnych zmian.. to łatwe choć bywa czasochłonne..
Dlatego do neta wypuszczam tylko sprawdzone zabawki, ale wcześniej testuję mody i skórki na localhoscie co zaoszczędza mi ew. pomyłek i problemów..

Kiedy już mam zainstalowanego moda to również kopiuje pliki tylko zmienione do folderu "poinst_nazwa_Moda"
To było obrazowo, a dokładniej to mam katalog z nazwą forum/ w nim katalod - "mody"/ a w nimkażdy mod ma swoją zawę katalogu i każdym z nich są 2, czasami trzy foldery własnie n. przed_..., poinst_... ale mam też folder dell_Nazwa_Moda i do niego wrzucam komplecik po udanym odinstalowaniu. To się później naprawdę przydaje.. szczególnie jak ktoś to robi po kilka razy..

No cóż masz trochę roboty, ale nie pękaj, dasz radę, tylko sporo roboty.. a może to bzecik w jakimś pliku?
Możesz też podmieniać tylko te które miał modyfikowac mod. (z czystej instalki) - wtedy też odkryjesz winowajcę..

Przejrzyj pliki i napisz coś dokładniej.

Pozdrawiam
roco





Attention! Testing modifications - Steam Profile

IP IP Zapisane
Technik
*****
Offline
25.12.2013 19:54:28
Topic Starter
 Poland Mężczyzna
Poland
 
DATA: [12.07.2009 11:49:43] Odp: Błędy parsowania
Link:  https://poligon.ricoroco.com/fora/smf/index.php?topic=309.msg869#msg869 Post #2 
No siema roco

No więc tak. Jaja zaczęły dziać się po zmianie stylu. Jak już Ci pisałem w wątku z avatarami zmieniłem z MysticJade na DS Natural. I wszystko działało w miarę oki. Odinstalowałem nneonneo shoutbox. Podczas deinstalacji wystąpiły błędy więc spisałem sobie co trzeba poprawić i usunąłem zbędny kod ręcznie. Tak sam było z kilkoma innymi  modami, niektóre odinstalowały się ładnie z automatu. Przez ostatnie dni korzystałem praktycznie z wszystkiego co mam w PA czyli optymalizacji baz danych, sprawdzanie błędów, czyszczenia cache itd. Forum tak naprawdę z niewiadomych przyczyn posypało się wczoraj.

Przy rejestracji po wpisaniu wszystkich wymaganych pól i klinkięciu REJESTRUJ wyskakuje takie coś:



I nagle zaczęło walić samymi errorami  krzyk

W każdym logu powtarza się to:

Quote: [select]
8: Use of undefined constant  - assumed "



I dotycza tych powtarzających się plików:

Quote: [select]
Plik: /home/aresp2p/ftp/btinvites/Themes/ds-natural_20rc1/index.template.php (eval?)
Linia: 726



Quote: [select]
Plik: /home/aresp2p/ftp/btinvites/Sources/Load.php(2189) : eval()'d code
Linia: 726



I cały czas powtarzają się te dwa błędy.

Nie wiem co Ci tu jeszcze napisać. Błędy wywala praktycznie przy każdej akcji czyli cokolwiek robie, cokolwiek wcisne od razu wywala takie błędy potrafi wywalić te dwa błędy do każdej akcji więc log błędów jest od razu zawalony  Smutny




Attention! Testing modifications - Steam Profile

IP IP Zapisane
Administrator
*****
Imagination is more Important than Knowledge
Offline
08.05.2017 21:24:16
 United States Mężczyzna
United States
  WWW
DATA: [12.07.2009 12:37:10] Odp: Błędy parsowania
Link:  https://poligon.ricoroco.com/fora/smf/index.php?topic=309.msg870#msg870 Post #3 
Podmieniłeś plik index.template.php z tego stylu na czysty? tj nie modyfikowany z paczki Ds-Natural.

Wygląda jakby został jakiś kawałek stringu czy inne śmieci.. Porównaj pliki index.template z tej skórki, tj ten który masz na servie z tym który masz na swoim dysku na kompie z paczki.
Po za tym gdzie masz plik Register.template.php? czy jest on tylko w stylu default? Sprawdź czy nie ma tego pliku jeszcze w innych stylach, (nie powinno być) i podmień na oryginalny ze stylu default.
Jednak zacząłbym od przejrzenia plików pod kątem wpisów od sbox'a..
No i czeka Cię wycieczka, do bazy via PMA, w celu ustalenia, czy coś nie pozostawało.

W końcu ile tych modów odinstalowałeś?

Czy błędy się pojawiają na innym stylu?

Czy sprawdziłeś, czy mod dokonywał wpisów w głównym pliku index.php i czy zostały wpisy usunięte? Tam są wpisane akcje itd..

Draco, masz trochę sprawdzania, a ja krążę po omacku na ślepaka.. Piękna fotkę wkleiłeś, ale z niej tylko wynika, że wyskakuje error
Dalej twierdzę, że może to być bzdet, jednak musi zostać znaleziony. I po przejrzeniu plików pod kątem odwrócenia wpisów i sprawdzenia czy nie zostały jakieś śmieci, należy wykryć który z plików powoduje błąd np. index.template.php? --> to podmień na oryginalny z paczki stylu w celu wykluczenia.

Draco, musisz znaleźć, odkryć plik w którym jest problem! Jeśli to odkryjesz, to juz znalezienie samego błędu w pliku, to pikuś..

Sprawdź wszystko dokładnie, no niestety masz trochę roboty z tym, ale tak czasami bywa i nie ma co pękać.. Ja dalej mam za mało danych, żeby napisać coś konkretniej, ot zwykłe gdybanko.. z mojej strony..

Pomyśl i odpisz, mam nadzieję, że uda Ci się ustalic gdzie jest błąd, zastosuj metodę wykluczania.
Jeśli nie możesz dać z tym rady to pisz, będę próbował Ci coś podpowiadać, ale dalej potrzeba mi więcej info, np co jest w tej linii w pliku, gdzie smf loguje błąd..


Pozdrawiam
roco



Attention! Testing modifications - Steam Profile

IP IP Zapisane
Technik
*****
Offline
25.12.2013 19:54:28
Topic Starter
 Poland Mężczyzna
Poland
 
DATA: [12.07.2009 12:49:08] Odp: Błędy parsowania
Link:  https://poligon.ricoroco.com/fora/smf/index.php?topic=309.msg871#msg871 Post #4 
No i właśnie chciałem pisać edit do mojego postu powyżej ale widze, że juz odpisałeś 

No więc zacząłem grzebać w PA i na FTP ... hmm sam nie wiem jak to zrobiłem ale rejestracja już działa 

Jeżeli chodzi o plik Register.template to pobiera on go z defaulta, ta skórka ma tylko swój index.template.php resztę pobiera z defaulta.

Dlatego też zrobię tak jak mówiłeś i przejże każdy plik z osobna i zaczne od index.template. Wiem, że czasochłonne ale cóż jak mus to mus. Zapewne coś zostało ze śmieci z poprzedniego stylu. Odinstalowałem 4-5 modów z czego tylko 2 odinstalowały się bez błędu a pozostałe musiałem usuwać ręcznie kod, które zostawiły. Dlatego mniemam, że coś pozostawiło jakiś farfocel. Oczopląsu pewnie dzisiaj dostane ale zaraz zabieram się do przeglądania plików. Zgłoszę się jak znajde (lub nie) przyczynę.

Może kolejny topic będzie można oznaczyć jako SOLVED 

pozdrawiam



Attention! Testing modifications - Steam Profile

IP IP Zapisane
Administrator
*****
Imagination is more Important than Knowledge
Offline
08.05.2017 21:24:16
 United States Mężczyzna
United States
  WWW
DATA: [12.07.2009 13:18:11] Odp: Błędy parsowania
Link:  https://poligon.ricoroco.com/fora/smf/index.php?topic=309.msg872#msg872 Post #5 
Draco, chodzi o to, że niektóre mody nie dopisują Tylko.. swoich wpisów, ale niektóre z nich, zamieniają wpisy na swoje, więc istnieje również duże prawdopodobieństwo, że zostało coś usunięte.. co jest potrzebne, lub faktycznie pozostały wpisy.

lepiej by było zintegrować to co masz, czyli Twoje wpisy, wpisy od innych modów, buttony itd.., na nowej wersji pliku i podmienić.

Spróbuj zautomatyzować sobie pracę, np. stosuj edytor z podświetlaniem składni, np. Notepad++, a do porównań plików stosuj np. WinMerge (+ pluginy). Dużo zaoszczędzisz na czasie. oczywiście nawet prostego edytora trza zrozumieć i się do niego przyzwyczaić, ale warto.

Dam Ci radę.. Nie rób niczego hurtowo, np. instalacji modów, a szczególnie ich odinstalowywania.. Zawsze posprawdzaj czy jest ok itd. To jest sporo pracy, ale to zawsze się opłaci - np. wiesz na czym stoisz, masz pewność, że wszystko wporzo od strony plików ect ect i jak się co wywali, to masz o wiele mniej roboty i od razu można wykluczyć parę rzeczy..

Porównaj pliki, i dointegruj do świeżego pliku index.template te mody które masz. I dopiero wtedy, kiedy dalej by było źle, to trzeba sprawdzić pliki również w "silniku" smf.. Ale rób wszystko systematycznie, step by step.
Przykro mi, że masz teraz trochę pracy, ale nie przejmuj się, to Cię tylko może rozwinąć hehe


Pozdrawiam
roco



Attention! Testing modifications - Steam Profile

IP IP Zapisane
Technik
*****
Offline
25.12.2013 19:54:28
Topic Starter
 Poland Mężczyzna
Poland
 
DATA: [13.07.2009 00:03:34] Odp: Błędy parsowania
Link:  https://poligon.ricoroco.com/fora/smf/index.php?topic=309.msg874#msg874 Post #6 
Siema Siema ponownie

No więc tak ... po południu znów padła rejestracja. Podłamany zacząłem przeglądać pliki. Error, który wyskakiwał w index.template od stylu DS Natural porównałem z oryginałem i ... okazało się, że są identyczne, ten mój "zmodyfikowany" miał dodany tylko 3 linijki od kodu Shoutboxa, poza tym nie różnił się niczym od oryginalnego! No więc przystąpiłem do przeglądania innych plików ... podmieniłem plik Register.template na nowy "czyściutki" ze świeżej instalki ... nic nie dało ... w końcu zrezygnowanemu coś mi błysnęło w głowie (nie wiem czy to dobrze czy źle  ) a mianowicie wszystkie błędy parsowania stylu odnosiły się do plików w cache z językiem polish utf-8 . No więc po kolei przeszłem na styl default, wyczyściłem logi z błędów, wyczyściłem cache i zmieniłem domyślny język na angielski. Po czym wróciłem do stylu DS Natural. W tym czasie nie występowały żadne błędy parsowania! Ale w logach wystąpił błąd - na szczęscie tylko jeden i odnosił się do akcji =register2 oraz zawierał komunikat (nie pamiętam dokładnie co pisało), że niedozwolone akcje z jakiegoś IP. Skojarzyło mi się, że mam zainstalowanego Bot Bustera. Odinstalowałem go, po czym ponownie wyczyściłem cache i ... forum śmiga na języku angielskim ,nie wywala żadnych błędów parsowania, nie wywala żadnych błędów w logach w PA, rejestracja odbywa się noramalnie (przynajmniej narazie) ...

No więc nie wiem czy co do samej rejestracji gdzie wywalało błąd bez dokładnego komunikatu nie mieszał coś mod Bot Buster ... a jeżeli chodzi o błędy parsowania czy nie zmieszało się coś w języku polskim? Czy to możliwe?

Myśle nad usunięcie polskiego oraz wgraniem go od nowa tylko czy znów nie zacznie sypać błędami?

Pozdro

... ide dalej walczyć  drinks tylko nie wiem jak jeszcze długo dam rade bo browar się konczy  stres



Attention! Testing modifications - Steam Profile

IP IP Zapisane
Administrator
*****
Imagination is more Important than Knowledge
Offline
08.05.2017 21:24:16
 United States Mężczyzna
United States
  WWW
DATA: [13.07.2009 04:28:57] Odp: Błędy parsowania
Link:  https://poligon.ricoroco.com/fora/smf/index.php?topic=309.msg875#msg875 Post #7 
Samo się nic nie dzieje, jeśli jest error, to ma swoją przyczynę.
Pamiętaj, że miałeś trochę modów i kilka odinstalowałeś, jeśli byłoby ok to spoko, jednak zrobiłeś to hurtowo i coś się wywaliło i teraz to oznacza, że tak naprawdę powinieneś porównać pliki, wszystkie, które brały udział w instalowaniu/odinstalowaniu. Mówię tu o ostatnim czasie, kiedy odinstalowałeś kilka modów.
Chodzi o porównanie oryginałów do plików które teraz masz, najlepiej edytorem do porównań. Jak również porównanie do tego co było w paczkach z modami, które odinstalowałeś i na koniec trzeba uwzględnić Twoje własne modyfikacje. Na pewno byłoby prościej, gdybyś odinstalowywał po sztuce i sprawdzał czy wsio ok.. ale jest jak jest, nie?

Oczywiście możesz wymienić pliki uwzględniając wpisy od modów. Może są jakieś nowsze i lepsze?
Po każdej takiej operacji, ja bym wszedł do katalogu cache na ftp i wychlastał wsio co tam jest, poza plikiem .htaccess. Zresztą to samo się dzieje po wyczyszczeniu cache z tym, że od razu powstają tam pliki już z miejsca w którym jesteś. "Dotkliwiej" można wychlastać ręcznie na ftp, wyczyścić kompletnie cache browsera i ciastka, + sesje i odświeżyć stronę - [F5].
Zawsze po zmianach trzeba się liczyć z tym, że będą errory ze strony cache, jednak jest ono bardzo potrzebne i nie należy go wyłączać, ponieważ zaoszczędzasz na odwołaniach do plików i bazy. reasumując, mechanizm cache będzie Ci podrzucał ciągle starsze kopie plików. To ważna informacja i chodzi o to, żeby się tym nie przejmować, tylko parę razy odświeżyć stronę, wyczyścić cache.. Przy każdej modyfikacji czy zmianie, np. języka.. nawet kiedy podmienisz pliki np polskie na polskie, ale będą się różnic, to różnice zauważysz dopiero, kiedy oczyścisz cache i napełni się ono nowymi plikami. Gł. są tam trzymane kopie plików które były ostatnio w użyciu, więc kiedy już dokonasz zmian czy instalek, lub od-instalek, to czyścisz cache i klikasz wszędzie gdzie się da, żeby cache zapełniło zdrowymi plikami...

W ogóle z niczym nie pękaj, ale dobrze by było ustalić co powoduje błąd. Np. Bot Buster, miałeś jakieś tłumaczenie tego moda? tj. wpisy od niego? Niektóre mody wymagają swoich wpisów językowych lub całych plików direct w stylu, który aktualnie używamy, tak mogło być i z tym modem. Np. odwoływał się do jakiegoś polecenia, lub zwykłe wyświetlenie linka, ale anchor był opisany w pliku językowym, wiec zamiast odwołać się do pliku językowego najpierw w stylu, którego używasz, a jak nie ma to spoko wybiera z defaultowego, ale nie zawsze tak jest, czasami nie widzi wpisów, lub pliku, językowego w danym stylu i nie odwoła się do defaultowego, tylko od razu masz errora, ile razy ktoś odwiedzi stronę gdzie występuje ten wpis.

Może się okazać, że Twoje nerwy były niepotrzebne, ponieważ to jakiś bzdet.. tylko trzeba go znaleźć.. hehe

Zajrzyj do tych plików językowych zobacz co tam masz i czy jest wsio co powinno. Po ręcznym wyczyszczeniu cache zmień język na pl, znowu oczyść cache ale teraz normalnie z PA forum i poklikaj wszędzie, gdzie się da.. zeby nałapało plików do cache. Postaraj się, żeby nie było błedów z plikami językowymi, np. ściągnij ostatnie wersje i uzupełnij o swoje wpisy, tj. od modów.. i podmień na servie, wyczyść ręcznie cache i zmień język na PL.. Trochę z tym zabawy, ale warto to zrobić.. to nie jest smf1.1.9 gdzie możesz znacznie więcej, w sensie luzu, bo na smf 2.0 to juz inna śpiewka, 2 jest hmm bardziej "zasadnicza"

Musisz to posprawdzać, o czym tu napisałem.. trochę roboty, ale ustalić trzeba co jest nie tak, żeby Cię przypadkiem nie zawiodło w momencie kiedy będzie Ci zależeć..

Ok, nie wiem jakie tipsy mogę Ci jeszcze podrzucić, ale gadaj ze mną, może wpadniejsz na rozwiązanie.. jedno w tym jest smutne hehe samo się nie zrobi.. ale nie ma pękać, tylko trzeba naprawić!

Pozdrawiam
roco



Attention! Testing modifications - Steam Profile

IP IP Zapisane
Technik
*****
Offline
25.12.2013 19:54:28
Topic Starter
 Poland Mężczyzna
Poland
 
DATA: [14.07.2009 10:44:56] Odp: Błędy parsowania
Link:  https://poligon.ricoroco.com/fora/smf/index.php?topic=309.msg877#msg877 Post #8 
No więc na początek powiew że poradziłem sobie i wszystko śmiga ładnie i pięknie!

Po kolei: przejrzałem sporo plików, a zwłaszcza te, które były modyfikowane przez różne mody. Akurat żaden z zainstalowanych modów nie powodował problemów, za to znalazłem resztki po starych modach. Mniemam, że coś powodowało jakiś konflikt i dlatego sypało errorami. No więc wyczyściłem pliki z resztek które pozostawiły mody, usunąłem wszystkie pliki z cache (za wyjatkiem htaccess oczywiscie), następnie naklikałem toche na forum i ponownie wyczyściłem cache tym razem z poziomu PA. Potem usunąłem wszystkie pliki językowe od polskiego. Dla pewności przeszłem na default i wgrałem świeże pliki z polskim tłumaczeniem. Potem powrót na DS Natural i oczywiście przy każdej operacji czyszczenie cache z poziomu PA. Na koniec ustawiłem polski język jako domyślny i tak już zostało i do dnia dzisiejszego nie wywaliło ani jednego błędu, forum śmiga pięknie. Aha zoptywalizowałem jeszcze tabele w mysql via PHPMyAdmin. Jak potrafiłem tyle zrobiłem no i widać udało się.

Aha dzięki roco za podsunięcie WinMerge -> piękne urządzonko i bardzo przydatne. N++ już miałem od jakiegoś czasu ale WinMerge jest jak znalazł do porównywania plików.

Pozdro



Attention! Testing modifications - Steam Profile

IP IP Zapisane
Strony: [1]   TOP^Do góry
   Drukuj   
On-Line: 11 Gości, 0 Użytkowników
 
Skocz do:  

Podobne Tematy
  Temat Zaczęty przez Odpowiedzi Wyświetleń Ostatnia wiadomość
normal_post RSS błędy po zainstalowaniu Hack's Park Shoutbox spokojnie 5 2908 Ostatnia wiadomość 06.06.2009 13:43:31
Autor roco
normal_post RSS Skąd te błędy ? siler 6 2824 Ostatnia wiadomość 06.11.2009 02:33:37
Autor roco
normal_post RSS Podczas wysyłania wiadomości, pojawiły się następujące błędy: cieplutki 5 2701 Ostatnia wiadomość 05.08.2009 03:20:34
Autor roco
normal_post RSS Błędy stylu White Sandra 4 2533 Ostatnia wiadomość 22.02.2011 22:47:19
Autor Sandra
* Share this topic...
In a forum
[BBCode]
Code: [select]  -› [ Topic: Błędy parsowania ]
[url=https://poligon.ricoroco.com/fora/smf/index.php?topic=309.0]Błędy parsowania[/url]
In a site/blog
[xHTML]
Code: [select]  -› [ Topic: Błędy parsowania ]
<a href="https://poligon.ricoroco.com/fora/smf/index.php?topic=309.0" target="_blank">Błędy parsowania</a>
Geo Visitors Map