Strony: [1]   Bottom Do dołu
   Drukuj   
ico Autor    
[EN] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [RU]
     Topic: Dziwny problem z SSI  [Przeczytany 1731 razy]
0 użytkowników i 1 Gość przegląda ten wątek.
Customer
*
Offline
09.01.2010 22:23:13
Topic Starter
 Poland
Poland
 
DATA: [31.12.2009 04:00:05] Dziwny problem z SSI
Link:  http://poligon.ricoroco.com/fora/smf/index.php?topic=636.msg1504#msg1504  
Witam

Jestem właścicielem pewnej strony (i w pełnym znaczeniu amatorem php) klik klik oraz prowadze do niego forum klik klik. Postanowiłem odnowić ostatnio stronę i projekt strony znajduje się tutaj: http://www.mypegasus.pl/b/ . Postanowiłem że na stronie dodam informacje o ostatnich 5 tematach, które są omawiane na forum. Po przeszukaniu netu i stracie kilku godzin na główkowanie czemu u mnie nie działa doszedłem do wniosku, że działać nie może kiedy w pliku http://www.mypegasus.civ.pl/smf/ssi_examples.php Recent Topic jest kompletnie puste! Nie mam pojecia dlaczego i przeglądając net nie znalazłem na to pytanie odpowiedzi. Czuję się bezradny bo nie wiem gdzie mam już szukać rozwiazania  bezradny

Jako ciekawostke dopowiem, że mi na operze kod wyświetlający 5 ostatnich tematów działa a na ie i ff już nie. Co ciekawe prosiłem kolegę czy on ma ten sam efekt to okazało się ze na ff mu chodzi a na ie i operze nie.


IP IP Zapisane
Administrator
*****
Imagination is more Important than Knowledge
Offline
08.05.2017 21:24:16
 United States Mężczyzna
United States
  WWW
DATA: [31.12.2009 05:26:28] Odp: Dziwny problem z SSI
Link:  http://poligon.ricoroco.com/fora/smf/index.php?topic=636.msg1505#msg1505 Post #1 
Witam

Może zacznijmy od tego, że masz wersję 1.1.4, to trochę sitko i można Cię zahakować, ale pewnie to wiesz..
To był taki siup, już nie pamietam chyba poprawili w wersji 1.1.5 lub 1.1.6.

Spróbuj w ten sposób:

PA >> Obsługa Forum >> i po kolei:

1. - Sprawdź i napraw wszystkie błędy. (najpierw je przejrzyj, może coś ważnego?)
2. - usuń nieważne raporty
3. - Przelicz statystyki Forum
4. - Zoptymalizuj wszystkie tabele w bazie
4a. - zrób to również na hostingu via PMA (zaznacz wszystkie tabele i wybierz z rozwijanego meny na dole -> Optymailzuj zaznaczone)


Sprawdź czy pomogło. Jeśli nie, to w opcjach zmień ilość wyświetlanych ostatnich wątków na stronie gł. forum, np. daj 12, sprawdź, później daj 8 i sprawdź, później daj 10.

Jeśli jednak dalej lipa, to chciałbym wiedzieć, czy forum było przenoszone, czy to się stało (właśnie - kiedy, po jakiej akcji), np. po usunięciu jakiś topów?

Możesz na własną rękę:
Wyedytuj plik SSI.php i odnajdź:

GeSHi -› Code: [select]
// Recent post list:   [board] Subject by Poster    Date
function ssi_recentPosts($num_recent = 8, $exclude_boards = null, $output_method = 'echo')
{
// Created by GeSHi 1.0.8.10 | code: -› [code=PHP] | load:0.030s | speed:4.68 KB/s



to $num_recent zmień na = 10

hmm ok, chyba mówiłeś o recent Topics to nie ma sprawy.. troszkę po nizej znajdziesz ssi_recentTopics:

GeSHi -› Code: [select]
// Recent topic list:   [board] Subject by Poster   Date
function ssi_recentTopics($num_recent = 8, $exclude_boards = null, $output_method = 'echo')
{
// Created by GeSHi 1.0.8.10 | code: -› [code=PHP] | load:0.038s | speed:3.84 KB/s



Zmień na = 10 i sprawdź efekt, powinno pomóc.. tak sądzę.. Jednak był we wcześniejszych wersjach problem z SSI
Pamiętam, że to w ten sposób obszedłem, później były jakieś poprawki bezpieczeństwa i btw usunęli również i ten problem.

Mam nadzieję, że te informacje okażą się dla Ciebie pomocne.

Pozdrawiam
roco

BTW, żeby się zaktualizować to musisz przejść te wszystkie patche, po kolei. ew, jak mało modów, to podmień pliki, aktualizując swoje modyfikacje.

.



Attention! Testing modifications - Steam Profile

IP IP Zapisane
Customer
*
Offline
09.01.2010 22:23:13
Topic Starter
 Poland
Poland
 
DATA: [31.12.2009 12:22:13] Odp: Dziwny problem z SSI
Link:  http://poligon.ricoroco.com/fora/smf/index.php?topic=636.msg1512#msg1512 Post #2 
Dziekuje za odpowiedz ale niestety efekt moich zmian dopiero opisze jak wroce po sylwestrze. Milej zabawy zycze wszystkim locospoco


IP IP Zapisane
Administrator
*****
Imagination is more Important than Knowledge
Offline
08.05.2017 21:24:16
 United States Mężczyzna
United States
  WWW
DATA: [31.12.2009 19:43:45] Odp: Dziwny problem z SSI
Link:  http://poligon.ricoroco.com/fora/smf/index.php?topic=636.msg1522#msg1522 Post #3 
Spoko, dla Ciebie też miłej zabawy i Dosiego Roku 2o1o  yahoo

jak już dojdziesz do siebie, to napisz o co kaman.

Pozdrawiam
roco



Attention! Testing modifications - Steam Profile

IP IP Zapisane
Customer
*
Offline
09.01.2010 22:23:13
Topic Starter
 Poland
Poland
 
DATA: [02.01.2010 00:56:59] Odp: Dziwny problem z SSI
Link:  http://poligon.ricoroco.com/fora/smf/index.php?topic=636.msg1532#msg1532 Post #4 
Impreza byla udana  Cool

Co do forum - wykonałem wszystkie Twoje polecenia no i na operze pojawily sie informacje w recent topic i recent post ale tylko w operze i to dopiero po recznej edycji pliku SSi.php. IE dalej nic nie pokazuje. W ogole mialem 19300 bledow - wszystkie spowodowane zlym dzialaniem shouta - odinstalowalem go. zostalo mi jak widac zaktualizowanie forum do nowsszej wersji.

EDIT: zaktualizowałem do 1.11 i też efektu brak.... krzyk


IP IP Zapisane
Administrator
*****
Imagination is more Important than Knowledge
Offline
08.05.2017 21:24:16
 United States Mężczyzna
United States
  WWW
DATA: [02.01.2010 01:41:41] Odp: Dziwny problem z SSI
Link:  http://poligon.ricoroco.com/fora/smf/index.php?topic=636.msg1533#msg1533 Post #5 
Witam w nowym roku 2o10

To zdecydowanie najlepsze rozwiązanie z uwagi na to, że jeśli poważnie traktujesz to co robisz, to aktualki i tak nieuniknione..

Ja bym to zrobił tak:

- kopia plików i bazy z poziomu PMA
- wyczyszczenie wszystkich wpisów w raportach błędów
- odinstalowanie wszystkich modów (nie pękaj to zrobić)
- krokowa aktualizacja, ew. przy problemach podmiana plików na czyste z tej samej wersji i wtedy aktualka

Kiedy znajdziesz się docelowo na 1.1.10, to po za oboma plikami Setting - wymień wszystkie pliki, na nowe z ostatniej paczki na smf.org

Generalnie to od tego bym zaczął. To świetny skrypt, naprawdę! i jest sporo różnic między 1.1.4 a 1.1.10.
Spróbowałbym jeszcze czegoś innego. Obok forum zainstalowałbym czyste w ostatniej wersji - 1.1.10, zrobił kopię bazy a następnie zaimportowałbym bazę którą możesz pobrać z poziomu PA Twojego forum, tj. nie całość tylko zawartość bez tabel. Pewnie trzebaby wyczyścić tabele przed importem, ale później wiesz, poprawienie kilku ścieżek i jeśli to rozwiązanie by zadziałało, to masz zaoszczędzone sporo czasu.. i masz forum w ostatniej wersji. Wtedy export i import do właściwej bazy z tej nowej, ew. tworzysz na hostingu zupełnie nową bazę z userem, keyem i prawami ustawionymi na ALL potem tam importujesz, z tego nowego forum, gdzie już baza została uaktualniona o wpisy z Twojego gł. forum. Później tylko podłączasz tę bazę w plikach Settings (obu!)

Jest kilka sposobów jak widać, więc, przemyśl to sobie i moja rada jest taka, - nic innego nie rób dokąd nie staniesz na ostatniej wersji skryptu smf.

Pisałem to tzw. skrótem myślowym, ale sądzę, że załapałeś, jeśli nie to pisz. I zdecydowanie rób wszystko po kolei, step by step, a w brew pozom, może.., uporasz się z całością dość szybko!, to o czym napisałem wyżej, to na luziku, popijając piwko może dwa, w godzinkę można zrobić. Niestety masz tę kobyłkę do przepchnięcia, ale opłaci Ci się odświeżyć wszystko. Wtedy zastanów się jakie mody są Ci naprawdę niezbędne, a jakie nie. Możesz pytać również o to, czyli o sens instalek różnych modów.., czasem można to zrobić prościej i bez wgrywania modów.
Ale kolejnym etapem powinno być uzupełnienie wszystkich potrzeb i dopiero na końcu, wszelkie integry.


Pozdrawiam
roco



Attention! Testing modifications - Steam Profile

IP IP Zapisane
Strony: [1]   TOP^Do góry
   Drukuj   
On-Line: 1 Gość, 0 Użytkowników
 
Skocz do:  

Podobne Tematy
  Temat Zaczęty przez Odpowiedzi Wyświetleń Ostatnia wiadomość
veryhot_post RSS Problem po przeprowadzce. « 1 2 3 » Sandra 29 6773 Ostatnia wiadomość 05.10.2008 16:14:47
Autor roco
hot_post RSS SSI i problem z kodowaniem « 1 2 » franko 14 3888 Ostatnia wiadomość 01.11.2008 06:56:50
Autor roco
normal_post RSS Dziwny plik cache Draco 3 1442 Ostatnia wiadomość 07.01.2010 10:57:57
Autor roco
normal_post RSS Problem z przyciskami... decisiveday 5 1778 Ostatnia wiadomość 31.01.2010 21:12:20
Autor roco
normal_post RSS Kodowanie w SMF2 - problem z polskimi ogonkami Sandra 5 2245 Ostatnia wiadomość 19.02.2010 23:24:15
Autor Sandra
normal_post RSS Ajax Chat Problem Cirmius 0 1151 Ostatnia wiadomość 14.09.2010 11:37:47
Autor Cirmius
* Share this topic...
In a forum
[BBCode]
Code: [select]  -› [ Topic: Dziwny problem z SSI ]
[url=http://poligon.ricoroco.com/fora/smf/index.php?topic=636.0]Dziwny problem z SSI[/url]
In a site/blog
[xHTML]
Code: [select]  -› [ Topic: Dziwny problem z SSI ]
<a href="http://poligon.ricoroco.com/fora/smf/index.php?topic=636.0" target="_blank">Dziwny problem z SSI</a>
Geo Visitors Map